zijian
V2EX  ›  问与答

Linux mysql 配置文件 my.cnf 一修改, mysql 就无法启动了

  •  
  •   zijian · Feb 5, 2020 · 4210 views
  •   You need to sign in to view this topic
    This topic created in 2433 days ago, the information mentioned may be changed or developed.
    遇到一个非常难缠的问题,由于自己的服务器更改了配置,想把 mysql 配置文件 my.cnf 也修改一下,可是只要一修改 my.cnf 文件,上传到服务器后,重启 mysql 就提示:

    Starting MySQL.. ERROR! The server quit without updating PID file (/usr/local/mysql/var/xxx.pid)

    这种情况该怎么办?各位老兄给指导一下,谢谢!

    BTW:重启 mysql 之前已经把原来的各种日志文件,原有的 xxx.pid 文件都删除了
    9 replies  •  2020-02-10 20:22:43 +08:00
    wtks1
        1
    wtks1  
       Feb 5, 2020 via Android   ❤️ 1
    直接用 vi 在服务器上修改试试?本地修改上传有时候会遇到编码问题
    zijian
        2
    zijian  
    OP
       Feb 5, 2020
    @wtks1 感谢建议,我对 vi 不熟,我刚才在保存的时候用的 encoding,选择 utf8,可还是不行
    wd
        3
    wd  
       Feb 5, 2020 via iPhone
    你这么测试 先不做任何修改传回去看看有没问题 然后加一个空行传回去 直到你找到一个加空行不出错的编辑器
    ipwx
        4
    ipwx  
       Feb 5, 2020
    不负责任的盲猜:你的本地操作系统是 Windows,本地编辑器的换行符是 \r\n,所以出错。试试把换行符都换成 \n。
    zijian
        5
    zijian  
    OP
       Feb 5, 2020
    @ipwx 我本地是 macOS 我试试你说的
    cominghome
        6
    cominghome  
       Feb 5, 2020
    你倒是看看 error.log 说的啥啊,盲猜是文件权限错误
    zijian
        7
    zijian  
    OP
       Feb 5, 2020
    @cominghome 我这边只有 /usr/local/nginx/logs/下面有一个 error.log ,但是里面没有相关错误记录
    noqwerty
        8
    noqwerty  
       Feb 6, 2020
    之前我这出这个错误是文件权限问题,把你传上去的文件 chown mysql:mysql 就好了
    zijian
        9
    zijian  
    OP
       Feb 10, 2020
    谢谢各位的建议,最后发现是用 sublime text 生成的文件编码有问题,换成 bbedit 就解决了,上传替换后重启 mysql 一切正常了。
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   895 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 30ms · UTC 23:32 · PVG 07:32 · LAX 16:32 · JFK 19:32
    ♥ Do have faith in what you're doing.